Sale 50% off

Editing Documents

Working with Tables

Tables are commonly used to organize text and numeric data. Sometimes, tables are used to arrange text or images on the page, such tables are usually made invisible.
Moving, resizing and other common operations work with tables just like with other objects.

Inserting and Removing Tables

To insert a table into the document, select Insert > Table.

To change the number or rows or columns of a new table, right-click on it and choose Edit Table… in the context menu. The Fixed Table Height option lets you vary the number of rows without changing the table height.

To remove a table, select it and press the Delete key.

Adding Rows and Columns

To insert a row, select a cell. Then open the context menu and choose the Add Row Above or Add Row Below command.

To insert a column, select a cell. Then open the context menu and choose the Add Column Before or Add Column After command.

The Tab key adds a new row when the bottom-right cell is currently highlighted.

Selecting a Table and its Elements

To select a table, click on it. To select an element of the table (cell or line), select the table and click inside a cell or on a divider.

The Tab key selects the next cell (in Z order). When the last cell is reached, pressing Tab adds a new row and selects the left cell in it. This also happens when the whole table is selected.

Pressing Shift-Tab selects the previous cell (in Z order). Once you reach the top left cell, pressing Shift-Tab selects the bottom right cell.

Resizing Columns and Rows

To resize a column or row, select the divider that separates it from another column or row, and drag it with the mouse.

The Fixed Table Height option lets you specify how the table reacts to the resizing of rows. To access this option, right-click on the table and choose Edit Table… When Fixed Table Height is activated, changing the row height affects the neighboring rows instead of the table size. With this option deactivated, increasing or decreasing the height of a row changes the table height. The heights of other rows remain constant.

Merging and Splitting Cells

By merging and splitting cells, you can create those that are bigger or smaller than others.

To merge cells, select them and choose the Merge Cells command from the context menu.

To split a cell, select it and choose the Split into Rows or Split into Columns command from the context menu.

Changing the Color of the Cell Background

To change the background color of one or more cells, select them and apply the Fill tool located in the Appearance tab (Cmd-3) of the Inspector.

Changing the Color and Width of the Borders

To change the color or width of the table border or divider, use the Stroke tools located in the Appearance tab (Cmd-3) of the Inspector.

Typing Text into Cells

To start typing text, double click on a cell.

To format text in a table, use the tools located in the Text tab of Inspector.

Inserting Images into Cells

To insert an image, select a table, then drag the image from the Source panel or from Finder, and drop it into a cell.

Another way to insert an image:

  1. Select a cell.
  2. Open the Appearance tab of Inspector.
  3. Click on the Image control and choose Custom Image….
  4. Select a graphic file.

There are several ways to fit an image into the cell:

Clearing Cells

To remove the content of the selected cell, choose Clear Cells in the context menu. You can clear several selected cells.

Clearing cells is useful when you want to reuse an existing table as a template for a new one. In this case, you can clear a part or the whole table to input new data.